Author Topic: AI not letting me play certain characters  (Read 1273 times)

Offline Destiny Talim

  • Jr. Member
  • **
  • Posts: 2
    • View Profile
AI not letting me play certain characters
« on: November 19, 2013, 03:27:47 AM »
How do you completely get rid of EVERY SINGLE ai file?  I can't play the character i want to right now because everytime I turn it on, it automatically closes and tells me there is an attempt at a nil value or something like that, and another thing tells me some ai file that i do or did have doesn't exist, when I'm looking right at it.  I'm just tired of using it and would like it completely off my computer so it never does that again.

Offline teh_hungry_cavalry

  • Hero Member
  • *****
  • Posts: 2845
    • View Profile
Re: AI not letting me play certain characters
« Reply #1 on: December 01, 2013, 10:11:08 PM »
Perform the step below with the game not running.

Download the default AI and extract it to the following directories:
1. C:\Program Files\Gravity\Ragnarok Online\AI
2. C:\Program Files\Gravity\Ragnarok Online\AI\USER_AI
« Last Edit: December 01, 2013, 10:12:46 PM by teh_hungry_cavalry »
[SIGPIC][/SIGPIC]
All work and no play makes a person... grind to death.
You Just Have to Deal with Me and My Conservative Arse. :gg:
Thanks to Feral for the Pic.

Offline NeoNilox

  • Jr. Member
  • **
  • Posts: 11
    • View Profile
Re: AI not letting me play certain characters
« Reply #2 on: December 10, 2013, 09:13:12 PM »
For the meantime, uncheck "hoai" in the config window:



This disables /hoai before getting into the game, but if a custom ai is vital, I'd tell ye to use the Doc's AI, which is the only AI that is actively updated, much to my dismay.

If really desperate, ye can also try to modify the first lines of all yer current .lua files, the AI. Like this:

Code: [Select]
require "./AI/USER_AI/Const.lua"If the code appears like that, it means it's outdated (THIS is the cause of these recent errors, I'm sure of it). Do it like this:

Code: [Select]
require "AI\\USER_AI\\Const"In a nutshell, remove the first period and the ".lua" and change each "/" into "\\".

It worked for me so far.

Reminder: When /hoai is disabled, uses the default AI (RODir/AI), otherwise uses the customized AI (RODir/AI/USER_AI).